Cara Membuat Transparent Web Proxy Mikrotik

Apa itu proxy? Proxy pada umumnya berfungsi untuk menyimpan cache website yang berasal dari url sebuah web. Apabila sebuah LAN menggunakan proxy untuk berhubungan dengan internet, maka seketika itu pula browser client mengakses url web dan akan mengambil request tersebut di proxy server. Dan jika data web belum tersedia dalam proxy, maka proxy akan mengambil langsung dari web yang bersangkutan.

Kali ini saya sedikit membahas bagaimana Cara Membuat Transparent Web Proxy Mikrotik. Selain management bandwidth, mikrotik juga dilengkapi dengan proxy, dan hasilnya request terhadap web atau url tertentu akan terasa lebih cepat apabila client meminta dengan alamat web yang sama dan proxy menyediakan tanpa harus meminta langsung ke internet.

Lalu, bagaimana cara konfigurasi proxy server di mikrotik? Berikut langkah-langkahnya:
  1. Login ke mikrotik dengan username dan password mikrotik
  2. Dalam hal ini saya mengetikkan perintah melalui console mikrotik karena lebih mudah dan cepat

    IP Proxy:
    /ip proxy set enabled=yes
    "mengaktifkan fiture web proxy"

    maximal-client-connections=1000
    maximal-server-connections=1000


    IP Web-Proxy:
    /ip web-proxy set enabled=yes
    "mengaktifkan web proxy (IP proxy dan IP web-proxy tergantung versi mikrotik"

    set src-address=0.0.0.0 "alamat yang kita gunakan untuk koneksi ke parent proxy (default-nya 0.0.0.0)"

    set port=8080 "port yang digunakan untuk web proxy"

    set hostname="proxy.andisyam.web.id" "nama hostname untuk web proxy (optional)"

    set transparent-proxy=yes "mengaktifkan transparent proxy"

    set parent-proxy=0.0.0.0 "sesuaikan jika kalian ingin menggunakan parent proxy (optional)"

    set cache-administrator="syam_u@bismillah.com" "email admin yang akan dikirim jika proxy mengalami error"

    set max-object-size=8192KiB "ukuran maksimal file yang akan disimpan sebagai cache (default=4096kilobytes)"

    set cache-drive=system "drive tempat menyimpan cache"

    set max-cache-size=unlimited "ukuran maksimal harddisk yang akan dipakai menyimpan file cache (4 kali total RAM atau unlimited)"

    set max-ram-cache-size=unlimited "maksimal ram yang digunakan untuk cache"

Cara redirect Proxy di mikrotik:

Membuat rule NAT untuk transparent proxy, dimana me-redirect port web ke transparent proxy yaitu mengarahkan semua trafik yang menuju port 80, 3128 dan 8000 kita belokkan menuju port 8080, yaitu port Web-Proxy:

/ip firewall nat add chain-dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080 "redirect port 80 ke port 8080 proxy server"

/ip firewall nat add chain-dstnat protocol=tcp dst-port=3128 action=redirect to-ports=8080

/ip firewall nat add chain-dstnat protocol=tcp dst-port=8000 action=redirect to-ports=8080


Memeriksa hasil konfigurasi NAT:

[admin@andisyam.web.id] > /ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic
0 chain=srcnat out-interface=public action=masquerade
1 chain=dstnat in-interface=local src-address=192.168.0.0/24 protocol=tcp dst-port=80 action=redirect to-ports=3128


Untuk melihat hasil konfigurasi web-proxy:

/ip web-proxy print


Monitoring kinerja web-proxy:

/ip web-proxy monitor


Nah, sampai di sini kita sudah dapat membuat transparent proxy di mesin mikrotik. Perlu diketahui untuk pertama kalinya memasang proxy, client tidak dapat mengakses sementara web yang dituju, hal ini disebabkan proxy akan me-request ke internet untuk men-cache permintaan pertama kalinya yang berasal dari client. Pada umumnya tidak berlangsung lama, tergantung koneksi kalian.

Semoga artikel ini bermanfaat, Amin!

Post Terkait:

Open Comments Close Comments

This site uses cookies from Google to deliver its services, to personalise ads and to analyse traffic. Information about your use of this site is shared with Google. By using this site, you agree to its use of cookies. Learn more